FTP ACCESS TO LOCAL HOSTS VIA PUBLIC IP Mikrotik


Sometimes you need access to ftp sites on your local networks with valid(public ip)

it was my problem but i solved it

local ip:192.168.0.0/24

ftp site:192.168.0.2

login to router with winbox or else

in section IP …….FIREWALL……NAT

you should add two rules

1./ip firewall nat add chain=dstnat action=dst-nat
to-addresses=192.168.0.2 protocol=tcp dst-address=!192.168.0.0/24
dst-address-type=local dst-port=21

 

2./ip firewall nat add chain=srcnat action=masquerade protocol=tcp src-address=192.168.0.0/24
dst-port=21

now you can connect to ftp site with public ip in your local network

Leave a comment

Your email address will not be published. Required fields are marked *